it-swarm-vi.com

Không thể cập nhật sấm sét

Gần đây tôi đã cài đặt Thunderbird 3.1 từ một số nguồn không phải là repos ubfox. Tôi không thể nhớ ngay bây giờ tôi đã lấy nó từ đâu (tôi nghĩ rằng nó được đóng gói như một cuộc tranh luận), nhưng tôi gặp vấn đề khi nó cố gắng tự động cập nhật.

Không giống như các phiên bản quản lý các bản cập nhật của họ thông qua repos, phiên bản này được cho là tự cập nhật bất cứ khi nào nó cần, có vẻ ổn, nhưng bất cứ khi nào nó thử, nó sẽ xuất hiện một lỗi:

Một bản cập nhật bảo mật và ổn định được đề xuất có sẵn, nhưng bạn không có quyền hệ thống cần thiết để cài đặt nó. Vui lòng liên hệ với quản trị viên hệ thống của bạn hoặc thử lại từ tài khoản có quyền cài đặt phần mềm trên máy tính này. Bạn luôn có thể tải xuống phiên bản Thunderbird mới nhất tại: http://mozillamessaging.com/en-US/Thunderbird

Có cách nào để cung cấp TB các quyền mà nó cần để mở dưới dạng root không?

4
mlissner

Không. Cách duy nhất để cho phép Thunderbird tự cập nhật là khởi chạy nó dưới quyền root hoặc tìm một nguồn khác xây dựng Thunderbird theo cách mà bạn có thể cài đặt hoàn toàn trong thư mục nhà riêng của mình.

Một tùy chọn tốt hơn, nếu bạn muốn chạy các ứng dụng tiên tiến, là cố gắng tìm ai đó tạo các bản dựng trên Launchpad PPA. Chúng có thể cập nhật thông qua hệ thống Synaptic/Nâng cấp thông thường, điều đó có nghĩa là bạn sẽ không gặp phải trường hợp góc như thế này. Khi điều đó xảy ra, nhóm Mozilla duy trì PPA của các phiên bản Firefox và Thunderbird mới hơn , bao gồm cả những cơn ác mộng. Nếu bạn cài đặt Thunderbird 3.1 từ đó, bạn sẽ là vàng.

4
Benjamin Pollack

Tôi vừa cập nhật. Trong thiết bị đầu cuối khởi động Thunderbird:

Chim sẻ Sudo

Sau đó, nó cập nhật với một vấn đề

Chúc may mắn

Anthony

0
TwoTone