it-swarm-vi.com

Không thể cài đặt bản dựng cần thiết trên CentOS

Khi tôi chạy lệnh:

Sudo apt-get install build-essential

Tôi nhận được thông báo lỗi sau:

Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package build-essential
79
Waley Chen

Tôi tin rằng điều này vẫn nên làm việc.

Sudo yum groupinstall 'Development Tools'
129
Scott Likens
yum install gcc gcc-c++ make 

Công việc này tương đương với build-essential trong CentOS.

48
Ketan Patel

Siêu phẩm build-essential được cung cấp trên Debian để thu thập tất cả các công cụ xây dựng cần thiết thường được yêu cầu trong chuỗi xây dựng Debian, bao gồm cả những công cụ bạn cần tạo .deb gói. Centos sử dụng một trình quản lý gói khác nhau hoàn toàn và không trực tiếp cung cấp bất cứ thứ gì như thế này; bạn sẽ cần cài đặt thủ công các thành phần riêng lẻ của chuỗi công cụ (gcc, make, thư viện phát triển chung, tài liệu, v.v., cũng như các công cụ để tạo các gói RPM nếu bạn muốn Để làm việc đó).

Nếu bạn thả .deb hoặc công cụ RPM, gcc, gcc-c++, glibc-develmake nên nhận các gói Centos tương ứng hiện tại.

5
tripleee

Tôi đã kết hợp giải pháp được chấp nhận từ Scott Likens với nhận xét từ user12345 và lần đầu tiên xem xét những gì trong nhóm "Công cụ phát triển" trước khi cài đặt.

Như user12345 đã chỉ ra, bạn có thể làm điều này với:

$ yum group info "Development Tools"

Tôi đã muốn cài đặt các gói như autoconfautomakebinutils, nhưng tôi không cần doxygen hoặc ant hoặc Mercurial.

Dưới đây là danh sách tôi đã sử dụng, cùng với sự phụ thuộc của họ, nhưng tất nhiên, số dặm của bạn có thể thay đổi, tùy thuộc vào nhu cầu của BẠN.

$ yum install \
    autoconf automake binutils \
    bison flex gcc gcc-c++ gettext \
    libtool make patch pkgconfig \
    redhat-rpm-config rpm-build rpm-sign \
    ctags elfutils indent patchutils 
2
m0j0
Sudo yum install -y libxml2 libxml2-devel libxslt libxslt-devel
0
Waley Chen